You are not logged in.

#1 2017-08-31 10:36 pm

shadowmaster
Member
From: Midwest, USA
Registered: 2014-12-20
Posts: 27
Website

stop forum spam EXTENSION not reporting to SFS

I finally got the SFS extension installed on a couple boards, set to check against ip and email and report to SFS. Seems to check and block just fine as it is leaving messages as such in my logs.
I.E:
Stop Forum Spam triggered:
Username: CaPiToRqZ
IP: 79.184.233.160
Email: jeremy@caroto.securemail.co.pl
   

But I'm not seeing the blocked spammers in MY SPAMMERS and when I do a search I cant find my reports in search results. I did double check my key to make sure I entered it correctly already.

I doubt this is on the SFS side, just wondering if anyone has any input.

Also, I know after a year the submissions drop out of MY Spammers, does this mean when it gets below 100 I will drop out of the Contributors List. Not a big deal really, it was just nice to make the list as I use to do all submissions manually. {Man that was a lot of work.}

Offline

#2 2017-08-31 11:53 pm

GarryRicketson
Moderator
From: Mexico
Registered: 2011-08-19
Posts: 1,260
Website

Re: stop forum spam EXTENSION not reporting to SFS

Is this the extension you are talking about ?
https://www.phpbb.com/customise/db/exte … orum_spam/

If it isn't , can you clarify on that ?

I recently had trouble figuring this out myself, and thanks to "sklerlder", in this thread:
https://www.stopforumspam.com/forum/vie … 681#p47681

As "admin", could you verify on your foum what you obtain with "http://wwwyourwebsiteurl/forumname/admin_statistics.php?action=phpinfo" page ? (this page can be viewed only with forum admin rights ...)
In "Core" part, you should have :
"allow_url_fopen    On    On"
If it's set to Off, you should modify your "php.ini" file to enable it ...

This was in relation to "FluxBB", but that is a non-issue, the main point is that the "php.ini"  or "php-5.6.ini", (will vary depending on the php version)
Any way, apparently it is set to "off" by default, in my case it was the last thing we checked,...now that I am aware of this, I would suggest it being the first thing to check.
How to edit the php.ini will depend partly on what OS the server is, most Linux,Unix servers it will be in /etc/php.ini.

Also note: I had to reload / restart the 'php-fpm.conf' for the changes to take effect, how to do that also might vary depending
on the OS/hosting/server, etc. 

============== edit ==========
Yes , if your submissions are below 100, for the year, then you will no longer show as a contributor,.. note though :

This list is updated hourly

https://www.stopforumspam.com/contributors

So for example, if tomorrow, you reach a point that the submissions are below 100, for the past year,...but the day after tomorrow,
you get hit with  over a 100 spammers, and submitted all of them, well, in the next update, you would end up back in the list.
So if for a few weeks, it is slow, and not many submissions you would "dissapear", but will show again as soon as (within a hour ) there is over 100 submissions.

Online

#3 2017-09-01 12:10 am

shadowmaster
Member
From: Midwest, USA
Registered: 2014-12-20
Posts: 27
Website

Re: stop forum spam EXTENSION not reporting to SFS

Thanks for the reply, and yes that is the extension.

Actually there is no problem yet. It occurred to me that blocked registrations won't be submitted, only posts that come from bots or spammers that listed in the SFS database. Guess I had a brain cramp.

I've only had a few the past year get through in the past year, now with the extension I'll bet it will be even less.

Thanks again.

Last edited by shadowmaster (2017-09-01 12:11 am)

Offline

Board footer

Powered by FluxBB

Close
Close